Critical update: Salesforce Upgrade to TLS 1.1

Salesforce are disabling support for TLS 1.0 in the near future.

This will have a critical impact on the usability of the FuseIT SFDC Explorer (and other systems connecting to the Salesforce APIs). Existing customers need to take action before June 2016 in Sandboxes and early 2017 in production orgs.

TLS 1.1 will be supported by Salesforce but earlier versions of the FuseIT SFDC Explorer were built on .NET Frameworks that do not support TLS 1.1 and therefore may not connect with Salesforce once TLS 1.0 has been disabled.

Short Term Solution 

Do not accept the Salesforce Critical Upgrade.

Login to your Salesforce instance and navigate to the Setup menu (under your user name). In the search text box search for "Critical Updates". Ensure the "Require TLS 1.1 or higher for HTTPS connections" update is not activated and note the number of days remaining before auto-activation will occur.

Permanent Solution

Please download the latest version of the FuseIT SFDC Explorer. Versions 3.0 onwards use the .NET 4.6.1 framework that has native support for TLS 1.1 and 1.2. If required, you can download the Microsoft .NET Framework 4.6.1.

Required TLS Config

 Note, the securityProtocols element must appear in the FuseIT.SFDC.Explorer.exe.config file to enable TLS 1.2 support. This might not be present if you are upgrading in place and an existing configuration file is in place.